Traineeship – FD_EngGrade_AL & FD_MathGrade_AL Errors

Home Forums Data issues Traineeship – FD_EngGrade_AL & FD_MathGrade_AL Errors

This topic contains 13 replies, has 4 voices, and was last updated by  DonT 5 years ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts

  • DonT
    Participant

    Hi everyone

    I’ve been trying to find out how to remove the English ‘FD_EngGrade_AL’ and Maths ‘FD_MathGrade_AL
    ‘ error message. The error message states ‘This field length has the incorrect number of characters’. Some of our learners on Traineeships don’t have GCSE’s. I have read the Annex Q and other guidance’s to no avail. Does anyone know how to clear this error message as I’m running out of steam!…

    Thanks

    Donna

     
    #19607
    SFA STAFF

    markshield
    Participant

    Don’t

    You are getting this error because you have either returned the field with no value in it (null value or whitespace) or have entered more than four character into the field.

    If your learners don’t have any GCSE’s then you return as specified in the ILR specification the word ‘NONE’ in these two fields.

    Regards
    Mark Shield
    ILR Specification Team
    Skills Funding Agency

     
    #19609

    DonT
    Participant

    Hi Mark

    I have entered ‘None’ in the field but it produces the following error message ‘The GCSE English qualification grade is not a valid code’

    Regards

    Donna

     
    #19610
    SFA STAFF

    markshield
    Participant

    Donna

    Is this your MI system producing the error or is this appearing on your FIS or HUB rule violations report?

    Regards
    Mark Shield
    ILR Specification Team
    Skills Funding Agency

     
    #19612

    DonT
    Participant

    Hi Mark

    The error is appearing on the FIS rule violations report.

    Regards

    Donna

     
    #19613
    SFA STAFF

    markshield
    Participant

    Donna

    Can you send me your file password protected to dataqueries@sfa.bis.gov.uk and the password on a separate email? I’ll take a quick look at your data.

    Regards
    Mark Shield
    ILR Specification Team
    Skills Funding Agency

     
    #19614

    DonT
    Participant

    Thanks Mark. Will email you the file tomorrow morning.

    Regards

    Donna

     
    #19615

    Garry Welborn
    Participant

    Hi,

    We have the same issue as Mark. Was there a resolution to this issue that could be shared?

    Regards

    Garry

     
    #19720

    Martin West
    Participant

    Hi Garry,
    I do not know if the issue was resolved for Donna but you should only record a valid GCSE grade (A*, A, B, C, D, E, F, U) or ‘NONE’ in these fields for all EFA learners.
    HTH

     
    #19721

    Garry Welborn
    Participant

    HI Martin,

    Thank you for your response.

    We’ve looked through the ILR specification and can’t see the look up table that includes ‘None’ as an option. Could you guide me to where I would find this please

    Thank you

    Garry

     
    #19723

    Martin West
    Participant

    Hi Garry,
    This is not included in the look up tables as the ILR specifications already includes that the requirement is for a valid GCSE grade and these are included in Appendix Q and the ‘None’ is referenced in the ILR specifications with:
    If a learner has not taken a GCSE xxx exam or has an equivalent overseas or other approved UK qualification then this field must be returned with the value of ‘NONE’.
    HTH

     
    #19725
    SFA STAFF

    markshield
    Participant

    For information, Donna’s issue was resolved as it was her MI system that was at fault by returning self closing XML tags for an empty field creating the FD errors and her MI system not allowing the value of ‘NONE’ to be selected.

    Regards
    Mark Shield
    ILR Specification Team
    Skills Funding Agency

     
    #19734

    Garry Welborn
    Participant

    Thank you Mark,

    I have forwarded your comments to our external MI system support

    Regards

    Garry

     
    #19737

    DonT
    Participant

    Hi Mark and Garry

    I did manage to resolve the issue. Thanks for all your assistance Mark but I’ve discovered it wasn’t my MI system that was at fault. I needed to add the word ‘NONE’ to both parts of the lookup within the examination grade awarded field of our MI System (in my case the Item code and Item Description had to contain the word ‘NONE’. Previous to this I only added the word ‘NONE’ to the description, and partially to the item code, that’s why it didn’t work). Garry try this method and see if it works. Please let me know if it does.

    Regards

    Donna

     
    #19738
Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.